Amperity is experiencing performance issues

Incident Report for Amperity

Resolved

This incident has been resolved.
Posted May 09, 2026 - 08:45 PDT

Investigating

Some parts of the Amperity platform are experiencing performance issues. We're working on the problem and expect it to be resolved shortly.
Posted May 08, 2026 - 10:55 PDT
This incident affected: Application (Website, Sources, Segments, Destinations) and Platforms (Azure Platform).